自鯖, FreeBSD

エラーメッセージをよく見ると

Hiki動作させたときのエラーメッセージを見てみると。下記表示だ。

Hiki Error
$SAFE=2 to 4 are obsolete (ArgumentError) /hiki/hiki/config.rb:231:in `block in load_cgi_conf'

となっている。Rubyの情報を見てみるとSAFEレベルの定義が変わったらしい。

 

 

config.rbを修正

ということで、config.rbの当該部分を修正する。

$SAFE = 4

$SAFE = 1

に変更してアクセスしてみると・・・成功。無事Hikiが起動した。

メニューに追加

メニューにHikiの項目を追加。とりあえず昔通りになった。

さよならHiki

 

自鯖, FreeBSD

VMで試しにHikiに必要なdiffdocをアンインストールしてからインストールしてみると動き出した…しばらくVMの方で様子を見てみるか。